Completed
Cloud Server Maintenance

Status
Resolved after less than a minute
Started
July 08, 2020 at 2:30 PM
Completed
July 08, 2020 at 2:30 PM
Affects
Website
  • Planned
    July 08, 2020 at 2:30 PM

    We are planning a scheduled maintenance during this time to optimize our Cloud Servers on AWS.

  • In progress
    July 08, 2020 at 2:30 PM

    Maintenance is now in progress.

  • Completed
    July 08, 2020 at 2:30 PM

    Maintenance has completed successfully.